גימפ

תגים: גרפיקה

מאת מאיר קריחלי, מיטל בורבין ושלומי פיש

מי זו גימפ?

גימפ זוהי תוכנת גרפיקה, בסגנון photoshop.

מאיפה אפשר להוריד אותה?

אם את/ה משתמש/ת בלינוקס, התקנ/י ממנהל החבילות שלך.

אם את/ה משתמש/ת בחלונות, הורד/י מהמהקישור הבא: http://gimp-win.sourceforge.net/stable.html ושם, בשביל להתקין את התוכנה, צריך להוריד ולהריץ (ובכך להתקין) את שני הקבצים הבאים: 1) The GIMP for Windows (version 2.2.17) 2) GTK+ 2 Runtime Environment (version 2.10.13, for Windows 2000 and newer) (תודה לטל גלילי על ההסבר המפורט על ההתקנה בחלונות)

ממשק התוכנה

ישנם 2 או 3 חלונות עיקריים(תלוי בברירת המחדל-האם השכבות נמצאות בחלון נפרד או לא). נניח שקיימים 2 חלונות במדריך זה.

החלון הראשי-חלון הכלים

132

כמו שאתם רואים, רוב הלחצנים ממוספרים. התפקידים של כל הלחצנים לפי המיספור שלידם הם:

1- בחירת שטח מלבני מתוך התמונה.

2- בחירת שטח עגול/אליפסה מתוך התמונה.

3- בחירת שטח באופן ידני.

4- בחירת שטח ע"י איזור מתמשך. פועל בעיקר לפי הבדלי צבעים. דומה ללחצן 5.

5- בחירת שטח ע"י הצבע שלו. לדוגמה אם יש תמונה של רמזור, אפשר לבחור את החלק הירוק שלו ע"י לחיצה על הלחצן הזה ואחריו על נקודה בשטח הירוק של התמונה.

הערה

בחירת השטחים ע"י לחצנים 1-5 משמשת בדר"כ על מנת לגזור/להעתיק/לשכפל/לשנות צבע של האיזור הנבחר.

9- להתקרב או להתרחק מהתמונה.

10- מודד אורך של קווים וזוויות. בוחרים בלחצן, ולוחצים עם הלחצן השמאלי של העכבר על המקום בתמונה שממנו רוצים למדוד. משאירים את העכבר לחוץ, ומזיזים אותו למקום שבו רוצים לסיים את המדידה. על מנת לראות את תוצאות המדידה, יש לסמן V ליד Use info window.

11- מזיז שכבות ואובייקטים. אם יש לדוגמה טקסט שהוכנס, ורוצים להזיז אותו, אז בוחרים בלחצן זה ואז לוחצים עם הלחצן השמאלי של העכבר על הטקסט וגוררים אותו למיקום הרצוי.

12- חיתוך או שינוי גודל של תמונה.

13- סיבוב השכבה או האובייקט.

14- שינוי גודל השכבה או האובייקט.

15- שינוי זווית השכבה או האובייקט. את האפקט של לחצן זה קשה לתאר במילים-לכן כדאי פשוט לנסות אותו ;)

16- שינוי נקודת המבט(פרספקטיבה) של השכבה או האובייקט.

17- הפיכת התמונה או השכבה אופקית ו/או אנכית.

18- הוספת ועיצוב טקסט.

19- צביעת רקע/צורות בצבע או עם דוגמאות.

20- מילוי הדרגתי בצבע.

21- ציור עם עפרון.

22- ציור עם מברשת.

23- מחיקה עד לשכבה של הרקע או לשכבה שקופה.

24- מברשת עם חוזק משתנה(שאת/ה קובע/ת).

25- ציור(רישום) בדיו.

26- ציור עם חותמות/דוגמאות.

27- טשטוש או חידוד.

28- לכלוך, טשטוש.

29-

30- צבע ראשון. (נקרא גם צבע FG)

31- צבע שני. (נקרא גם צבע BG)

טיפ

שני הצבעים משמשים לדוגמה כאשר רוצים לעשות רקע עם מילוי הדרגתי(לחצן מספר 20). נניח שרוצים רקע משתנה מכחול לסגול, אז צבע אחד יהיה כחול, והשני יהיה סגול.

32- החלפת הצבעים. הצבע של 30 והצבע של 31 מתחלפים במקומות.

טיפ

נניח שרוצים עכשיו שהרקע עם המילוי ההדרגתי יהיה מסגול לכחול, אבל כרגע הוא מכחול לסגול, אז במקום להכניס את הצבעים הפוך באופן ידני, אפשר ללחוץ על לחצן זה.

33- מציג את האפשרויות הקיימות ללחצן שבחרנו. לדוגמה אם בחרנו בלחצן של הוספת טקסט (לחצן 18), אז בחלון זה יופיעו הגופן, גודל הטקסט, וכו'.

34- מציג את השכבות הקיימות. ניתן לגרור לשונית זאת מהחלון הנוכחי שלה החוצה, ואז נוצר חלון נפרד של השכבות. יש אנשים שמעדיפים לעבוד עם 3 חלונות במקום 2.

תפריט File

New- פתיחת קובץ חדש. אפשר לבחור שם את הגודל שלו, האם יהיה לו רקע צבעוני או שקוף, האם הוא יהיה לאורך או לרוחב, ועוד...

Open- פתיחת קובץ או תמונה קיימים.

Open Location- פתיחת תמונה ע"י כתובת URL.

Open Recent- מציג את הקבצים/תמונות האחרונים שנפתחו בגימפ.

Preferences- הגדרות של הגימפ.

Quit- יציאה מהגימפ.

תפריט Xtns

Script-Fu- יצירת כפתורים, לוגואים, צורות תלת מיימדיות, ועוד...

החלון המשני-חלון העבודה

זה הוא בעצם החלון שנפתח לאחר שבוחרים ביצירת קובץ חדש או פתיחת קובץ קיים. זה החלון שבתכלס עובדים בו.

133

נעבור על אפשרויות חשובות בתפריטים שלו:

System Message: SEVERE/4 (<string>, line 146)

Title level inconsistent:

תפריט File
~~~~~~~~~~

New- פתיחת קובץ חדש.

Open- פתיחת קובץ קיים.

Open as Layer- פתיחת קובץ כשכבה. משתמשים בו לדוגמה כדי לשים תמונה חדשה על התמונה הקיימת.

Save, Save as- שמירת הקובץ בפורמטים שונים.

Close- סגירת החלון הנוכחי.

Quit- סגירת הגימפ.

System Message: SEVERE/4 (<string>, line 162)

Title level inconsistent:

תפריט Edit
~~~~~~~~~~

Undo- ביטול השינוי האחרון שנעשה.

Redo- חזרה למצב לפני הלחיצה על Undo.

Cut- גזירה.

Copy- העתקה.

Paste- הדבקה.

Fill with FG Color- ממלא בצבע הראשון (שבלחצן 30).

Fill with BG Color- ממלא בצבע השני (שבלחצן 31).

Fill with Pattern- ממלא בדוגמה/תבנית/שבלונה.

System Message: SEVERE/4 (<string>, line 181)

Title level inconsistent:

תפריט View
~~~~~~~~~~

Show Grid- הוספת רשת זמנית על התמונה.

System Message: SEVERE/4 (<string>, line 186)

Title level inconsistent:

תפריט Image
~~~~~~~~~~~

Duplicate- משכפל את התמונה הקיימת ופותח את השכפול בחלון חדש.

Mode- הפיכת התמונה לשחור-לבן (Grayscale) או לתמונת indexed (תמונות בדר"כ נשמרות כ-RGB, אך יש פעמים שבהן צריך לשמור אותן כ-indexed, כך שהוא שומר אותן בצורה שונה.)

טיפ

כדי ליצור תמונת splash בשביל ה-grub בלינוקס, צריך להשתמש ב-indexed.

Transform- שינוי הזווית והכיוון של התמונה.

Canvas size- שינוי גודל משטח העבודה.

Scale Image- שינוי גודל התמונה.

Configure Grid- שינוי התצורה של הרשת שניתן להוסיף מתפריט View.

System Message: SEVERE/4 (<string>, line 205)

Title level inconsistent:

תפריט Layer
~~~~~~~~~~~

New Layer- הוספת שכבה חדשה.

Duplicate Layer- שיכפול שכבה. השכבה החדשה נמצאת באותו חלון.

Merge Down- מיזוג שכבות.

Delete Layer- מחיקת שכבה.

Transform- שינוי הכיוון והזווית של השכבה.

Scale Layer- שינוי גודל השכבה.

הערה

העבודה עם שכבות תוסבר בהמשך המדריך.

System Message: SEVERE/4 (<string>, line 225)

Title level inconsistent:

תפריט Tools
~~~~~~~~~~~

מכיל בעיקר את הכלים שבחלון הראשי.

Color Picker- לוחצים איתו על צבע כלשהו שעל המסך והוא נותן נתונים על הצבע הנבחר.

System Message: SEVERE/4 (<string>, line 232)

Title level inconsistent:

תפריט Dialogs
~~~~~~~~~~~~~

מכיל את כל תיבות השיחה האפשריות בגימפ. (לדוגמה: שכבות, פונטים, כלים...)

System Message: SEVERE/4 (<string>, line 237)

Title level inconsistent:

תפריטי filters, Python-Fu, Script-fu
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

משמשים לאפקטים שונים. כדאי לנסות כל אפקט משם ולראות מה התוצאה שלו. ניסוי זאת הדרך המושלמת להכיר את כל הסקריפטים האפקטים הקיימים! ;)

העבודה עם שכבות

שימוש בשכבות מהווה טכניקה די בסיסית בעיבוד תמונה. נדגים את העבודה ב-gimp עם שכבות ע"י שילוב 3 תמונות לאחת. עוד נדגים תכונות נוספות של שכבות, כגון mask.

מבוא

נפתח את התמונות ב-gimp (ע"י file->open) בחלון הראשי:

134

כדי לא לפגוע בתמונות המקוריות, ניצור חדשה ונדביק אליה את התמונות האחרות. אני מעדיף לעבוד עם שכבת רקע נקיה, מה שמאפשר גמישות בשינוי הרקע, ללא פגיעה באלמנטים האחרים בתמונה.

לתיבת השיח של השכבות מגיעים בעזרת CTRL+L או בעזרת Dialogs | Layers מהתפריט של התמונה (טיפ: לתפריט אפשר להגיע גם עם קליק ימני על התמונה). כאשר עוברים מתמונה לתמונה, תוכן תיבת השיח משתנה בהתאם כמובן. נוסיף 3 שכבות חדשות לתמונה, בעזרת לחיצה על לחצן השכבה החדשה 3 פעמים.

לחיצה כפולה על שכבה תאפשר לנו לשנות את שמה. ניתן להן שמות קריאים (מה שיקל עלינו, במיוחד בתמונות מורכבות). לאחר מכן תיבת השיח של השכבות תראה כך:

135

כמו שניתן לראות, יצרתי את השכבות בסדר שגוי. התמונה דורשת ספר מתחת לפינגווין ועפרון מעל. אל חשש, אפשר לשנות את סדר השכבות בעזרת לחצני החיצים בתיבת השיח של השכבות.

כעת נעתיק ונדביק את התמונות השונות. חשוב לשים לב שנמצאים בשכבה הנכונה לפני ההדבקה. בוחרים את השכבה הפעילה בעזרת לחיצה עליה בתיבת השיח של השכבות. שיניתי מעט את גודל התמונה של Tux והזזתי את התמונות השונות על כל שכבה.

זכרו: פעולות עריכה מתבצעות על השכבה הפעילה כרגע (לדוגמא: הזזה, מילוי צבע, מתיחה וכן הלאה) ללא השפעה על שכבות אחרות.

עוד שימו לב כי תיבת השיח של השכבות מראה תמונה מוקטנת של כל שכבה:

136

מכאן תוכלו להמשיך עם פעולות העריכה עד לשביעות רצונכם.

תכונות נוספות

לשכבות תכונות נוספות. אחת מהן היא השקיפות. בתיבת שיח השכבות מד ה-Opacity קובע את אחוז השקיפות של כל שכבה. 0% פירושה שקוף לחלוטין, 100% אין שקיפות. בוחרים בשכבה המבוקשת ומשנים את הערך. לצורך ההדגמה, מילאתי את הרקע בתבנית ושיניתי את אחוז השקיפות של שכבת העפרון:

137

לכל שכבה יש "מצב" - תיבת הבחירה Mode. תיבת זו מאפשרת לבצע פעולות מתמטיות או לוגיות שונות על כל שכבה עם השכבות מתחתיה (כגון: הכפלת הערכים, חיבור, הבהרה בלבד וכן הלאה). בתמונה הבאה שיניתי את מצב שכבת הספר ל-"Subtract" (חיסור):

138

כדי לחזור למצב הרגיל, בוחרים ב-Normal.

לשכבה אפשר להוסיף ערוץ מיסוך המאפשר לשלוט על ערך השקיפות ותכונות דומות עד לרמת הפיקסל. החזרתי את מצב שכבת הספר לנורמלי, והוספתי מיסוך לשכבה בעזרת לחיצה ימנית על השכבה ובחירת "Add Layer Mask". בתיבה שנפתחה קיימות מספר אפשרויות, אנו נתרכז ב-white (אין שקיפות) ו-Black (שקיפות מלאה). נבחר בללא שקיפות. כעת נוספה בצד ימין של התצלום המוקטן תמונה מוקטנת נוספת של המיסוך (כרגע לבנה כולה):

139

ניתן להחליף בין עבודה על ערוץ המיסוך לתוכן השכבה בעזרת לחיצה על התצלומים המוקטנים שלהם. נשתמש בכלי ה-Gradient Fill כדי לצבוע את ערוץ המיסוך משחור ללבן. שימו לב לאפקט על שכבת הספר:

140

ניתן גם להעלים שכבות בעזרת לחיצה על לחצן ה"עין" ליד כל שכבה. מדוע שנרצה לעשות זאת ? לשמור גרסה של התמונה ללא אלמנט מסויים, או בעת מיזוג שכבות (לאחר שסיימנו לעבוד על תכונות נפרדות של אלמנט מסויים), למזג רק את אלו הנראות, וכן הלאה:

141

קישורים חיצוניים

http://whatsup.org.il/modules.php?op=modload&name=News&file=article&sid=3879 (מתכון לשבת: עוגת שכבות עם הגימפ)

http://whatsup.org.il/modules.php?op=modload&name=News&file=article&sid=4374 (הרחיבו לכם את ה-Gimp)

http://whatsup.org.il/modules.php?op=modload&name=News&file=article&sid=4416 (הרחיבו את ה-Gimp: חלק ב')

http://gimp-savvy.com/BOOK/index.html?Grokking_the_GIMP.html (אנגלית)

כיצד לקבל עזרה לגימפ?

ראשית, ניתן לשאול אנשים ברי סמכא באמצעות ה-IRC שהוא פרוטוקול שיחה אינטרנטית פתוח:

http://wiki.gimp.org/gimp/Irc

ניתן גם לשאול ברשימת הדיוור gimp-user:

https://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

בשני משאבים אלה יש לשאול באנגלית.

ניתן למצוא קישורים לתיעוד באתר של גימפ:

http://www.gimp.org/

ובוויקי של גימפ:

http://wiki.gimp.org/gimp/